[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Search]

Re: Severe issue installing emacspeak for Ubuntu users

Here are some notes for an accessible install from source that someone sent me on the Orca list.
Hope they help someone.
*** Installing Emacs 24

$ sudo apt-get install emacs24

If you want to install Emacs snapshots, which come out every couple of days, I came across the following. I didn't have any trouble with the snapshots, but I don't need to be on the bleeding edge when it comes to Emacs, and my apt-get upgrade runs more quickly if I just stick with Emacs24.

I got the following instructions from http://sinewalker.wordpress.com/2012/02/13/install-emacs24-snapshot-on-debian-ubuntu-and-windows-7/


I’m running Ubuntu 11.10 in a VirtualBox on work’s Windows 7 machine. As mentioned at Julien Danjou’s page, Damien Cassou makes a version of the same emacs-snapshot for Ubuntu, which is hosted at Launchpad. You add it and install simalarly:

Add the PPA (Personal Package Archive). This also imports the key:

$ sudo add-apt-repository ppa:cassou/emacs

Update your package database

$ sudo apt-get update

Install emacs-snapshot

$ sudo apt-get install emacs-snapshot

*** Installing Emacspeak

**** Getting and Making Emacspeak

I downloaded the latest Emacspeak, emacspeak-37.0.tar.bz2, from http://code.google.com/p/emacspeak/.

fter unpacking this file, I went into the resulting directory, i.e. emacspeak-37.0, and ran the following commands:

$ make config
$ make emacspeak

$ sudo apt-get install texinfo

$ sudo make install

Note that in the future I want to change the prefix to /usr/local before making Emacspeak, at least until I figure out how to package it.

I also went into /usr/bin/emacspeak and changed the last line to be:

exec emacs -l /usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el $INITSTR $CL_ALL

**** Making the eSpeak Server

I installed the following dependencies:

$ sudo apt-get install tcl8.4 tclx8.4 tk8.4 tcl8.4-dev libasound2-dev

I got this list from the Voxin scripts, but I need to double chek it.

I also needed to install the following development package:

$ sudo apt-get install libespeak-dev

I went into /usr/share/emacs/site-lisp/emacspeak/servers/linux-espeak and ran:

$ sudo make all

In the servers directory, I ran

$ ./espeak

to make sure the server was working.


$ emacspeak -e

came up with emacspeak talking and using eSpeak.

**** Recompiling eSpeak to Use PulseAudio

Unfortunately, the last syllable spoken is always truncated making it unusable.

(Note to bill: I've heard this has been changed in newer versions of Debian/Ubuntu, so this step may no longer be necessary. If you don't have the latency problem with truncated final syllables, just skip this step.)

I fixed this by downloading the source code for eSpeak and compiling it for runtime, which uses PulseAudio if it's running and PortAudio otherwise.

I went to http://espeak.sourceforge.net/download.html and downloaded the file espeak-1.46.02-source.zip.

I had to install the library development packages for PulseAudio and PortAudio.

$ sudo apt-get install libpulse-dev libportaudio-dev

Now after unpacking the source code for eSpeak, I went into the source directory, espeak-1.46.02-source/src, and I made the following changes to the Makefile:



# 'runtime' uses pulseaudio if it is running, else uses portaudio
AUDIO = runtime
#AUDIO = portaudio

Now I run the commands:

$ make all
$ make install

This creates new eSpeak libraries and binaries, using the runtime option, and places them in my ~/Tools directory.

Now to start Emacspeak with eSpeak and these new libraries, I run the commands:

$ export LD_LIBRARY_PATH=/home/chaltain/Tools/lib
$ emacspeak -e

aNow Emacspeak comes up and I don't have the latency issues.

I ended up adding the line

export LD_LIBRARY_PATH=/home/chaltain/Tools/lib

to the file /usr/bin/emacspeak.

Note that I exported the variable LD_LIBRARY_PATH instead of running the following command:

$ sudo ldconfig /home/chaltain/Tools/lib

so that I'd only run emacspeak with this new library and not making the change globally, so as not to impact Orca if I did something wrong.

When using ldconfig, note you can use

$ ldconfig -p | grep espeak

to see which eSpeak library is being used.

**** Getting Emacspeak with eSpeak to use an US English voice

Based on a tip I saw in a mailing list thread, I went into the file /usr/share/emacs/site-lisp/emacspeak/servers/linux-espeak/tclespeak.cpp, and I commented out the following line in the preferred languages section:

"en-uk", // english

and I added the following line:

"en-us", // english-us

I than ran $ sudo make.

After doing this, I no longer needed the line

(setq espeak-default-voice-string 'en-us)

in my ~/.emacs file.

Maybe if I'd just added the line for en-us then this variable setting might have been needed.

On 8/16/2013 9:22 PM, T. V. Raman wrote:
The emacspeak list is emacspeak@xxxxxxxxxxx -- you need to
subscribe to it. Copying this list on your message.
"cg" == cg  <cg@xxxxxxxxxxx> writes:
     cg> Dear Dr. Raman,
     cg> I have two questions:
     cg> 1) I tried to post the following on the emacspeak
     cg> mailinglist a few weeks ago. However, I wonder if it has
     cg> arrived at all, it seems the mailingserver isn't
     cg> working. I didn't receive any copies, and moreover, I do
     cg> not receive digest mails from the server at all. The same
     cg> holds for other people who I know have tried to use the
     cg> list.
     cg> 2) I would be very grateful if you could look into the
     cg> issue (see below).
     cg> Thanks in advance!
     cg> Chide Groenouwe,
     cg> from the Netherlands
     cg> -------- Original Message --------
     cg> 		SUBJECT: Severe issue installing emacspeak for
     cg> Ubuntu users
     cg> 		DATE: 2013-08-03 21:15
     cg> 		FROM: cg <cg@xxxxxxxxxxx>
     cg> 		TO: emacspeak@xxxxxxxxxxx
     cg> Dear Emacspeak developers, in particular Dr Raman,
     cg> Are you already aware of the following severe issue for
     cg> Ubuntu users (and related Linux distributions), (posted
     cg> by someone else, but also affects me, and others):
     cg> https://code.google.com/p/emacspeak/issues/detail?id=7&thanks=7&ts=1369589431
     cg> [2]
     cg> Here a copy paste:
     cg> What steps will reproduce the problem? 1. Install via apt
     cg> package 2. Run emacspeak &
     cg> What is the expected output? What do you see instead?
     cg> The expected output: 'a talking computer' But I see (and
     cg> three other people who tried it): process speaker not
     cg> running
     cg> What version of the product are you using? On what
     cg> operating system?
     cg> I am using the latest version in the apt repository of
     cg> ubuntu/linux mint. Details about my operation system:
     cg> Linux Mint 14 - 64 Bit
     cg> Please provide any additional information below.
     cg> I'm wondering if this bug is known by the emacspeak
     cg> community. I asked three other people running ubuntu if
     cg> it worked 'out of the box', but they got the same error
     cg> messages. I think that an application in the apt
     cg> repository must be capable of running directly, without
     cg> user interaction to fix broken things (see:
     cg> http://emacspeak.sourceforge.net/install-guide/troubleshooting.html
     cg> [1] ), I really like the opensource community and I have
     cg> a lot of respect for people who are programming in there
     cg> free time for others. I hope this bug can be fixed. Then
     cg> your product would be perfect!
     cg> Thanks in advance,
     cg> Chide Groenouwe
     cg> Links: ------ [1]
     cg> http://emacspeak.sourceforge.net/install-guide/troubleshooting.html
     cg> [2]
     cg> https://code.google.com/p/emacspeak/issues/detail?id=7&amp;thanks=7&amp;ts=1369589431

To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@xxxxxxxxxxx" with a
subject of "unsubscribe" or "help".

If you have questions about this archive or had problems using it, please send mail to:

priestdo@xxxxxxxxxxx No Soliciting!

Emacspeak List Archive | 2010 | 2009 | 2008 | 2007 | 2006 | 2005 | 2004 | 2003 | 2002 | 2001 | 2000 | 1999 | 1998 | Pre 1998

Emacspeak Files | Emacspeak Blog