[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Search]

[Emacspeak] Re: Crashes on macos on startup

Hi Isaac,

There are multiple recipes for Emacs under homebrew. There have been
other reports of problems with the 'plain' emacs homebrew recipe, so I
would strongly recommend using the rialwaycat recipe. To do this

1. Remove the existing emacs version with

brew uninstall emacs

2. Add the railwaycat cask

brew tap railwaycat/emacsmacport

3. Install the emacs-mac package

brew install emacs-mac

You can find out more about the railwaycat version at

Note that as this is a proper mac port of Emacs, you will find key
bindings are more consistent with normal mac key bindings. If you have
tweaked your Emacs init to get command and options to work correctly
(often required with vanilla builds of emacs for mac), you may want to
undo those changes. There are also some improvements with respect to
windows and full frame mode. However, I suspect as a blind user, your
probably just running Emacs inside a terminal rather thanin full GUI
mode? I have some limited sight, so I do use GUI mode. 

I would also consider upgrading your macOS version. The macOS Mojave
version falls out of support in November. I'm running macOS Big Sur on a
2014 mac book pro with no problems.

Note that reverting to an earlier version of Emacspeak and not seeing the
issue does not necessarily mean that the issue is with Emacspeak and it
is not a hardware issue. It all depends on how things are loaded in
memory. It could just as easily mean that the later versions of
Emacspeak cause additional or different memory allocation layout which
trips the problem. Most likely it is an issue with low level library
linking, but signal 11 crashes are frequently related to hardware
issues or corruption in low level libraries.

At any rate, it is highly unlikely this problem is due to Eamcspeak
itself. Emacspeak doesn't have any low level C code - everything is just
Emacs lisp. The type of error you are seeing looks like low level memory
allocation problems. This means it is much more likely the problem is
with Emacs and/or the low level libraries it is linked against. Even if
you don't want to replace the vanilla emacs version with the mac port
version, I would strongly recommend removing the existing Emacs, running
brew cleanup and re-installing to see if that fixes the issue. However,
I think the mac port of Emacs is really the best choice.

Likewise, upgrading to more recent version of macOS may also fix the
issue - especially if it is due to a low level shared library.

Hope all is going well at UON given lockdown etc. I'm located in
Armidale and worked at UNE for 20 years. I'm still involved with the
Comp Sci department there (member of the Industry Advisory Board). My
son was at UON until last year (doing Physics). It is a good Uni. 


Isaac Leonard via Emacspeak <emacspeak(a)emacspeak.org> writes:

> Hi Tim
> I'm studying at UON (University of Newcastle) in NSW.
> I'm running emacs
>  27.2 installed from homebrew.
>  I installed emacspeak from source with the git repo.
>  I'm running MacOS Mojave 10.14.6 on a macbook pro 2017 model.
>  I'd think it was emacs itself too however reverting emacspeak to
>  version 52.0 fixes the issue.
>  I've had no other memery issues in the past with emacs
>  and none with any other apps so I don't think its a hardware problem.
> I load emacspeak in my init.el with:
> (load-file "~/emacspeak/lisp/emacspeak-setup.el")
> which is the way specified in the docs.
> Tim Cross via Emacspeak <emacspeak(a)emacspeak.org> writes:
>> Hi Isaac,
>> welcome to the list.
>> What version of Emacs and how did you install it on the mac?
>> What version of macOS are you running?
>> That error would indicate a problem in Emacs rather than Emacspeak.
>> There are various different ways of installing Emacs on the mac. I've
>> found the best results are with the railwaycat mac-port homebrew recipe
>> of Emacs. The mac-port version is a modified version of Emacs
>> specifically built for the mac. One of its nice features is that it has
>> a variable you can set to turn off voiceOver when running Emacs inside a
>> terminal. I would also ensure your using Emacs 27 and not current
>> development version 28.
>> It does look like a memory allocation problem. My biggest concern is
>> that this type of error is often associated with a hardware issue i.e.
>> bad membory. That may not be the case, but is a possibility. 
>> BTW which University are you studying at?
>> Tim
>> Isaac Leonard via Emacspeak <emacspeak(a)emacspeak.org> writes:
>>> Hi all, I am new to the mailing list and to mailing lists in general.
>>> I saw that I should introduce myself so here goes
>>> I am a 21 year old programmer from australia, I am totally blind  and
>>> have used emacspeak for around 2 years now.
>>> I am currently studying computer science at university and mainly use
>>> emacs for all of my writing when possible.
>>> I've recently had an issue with emacspeak crashing when I start emacs.
>>> A few months ago when version 53 was released I tried to upgrade however
>>> it caused emacs to crash on startup around 50% of the time.
>>> I reverted to version 52.0 until the other day when I decided to try
>>> upgrade again to version 54.0 and just deal with the crashes.
>>> Yesterday however I attempted to open emacs 4 times in a row with
>>> it crashing each time so decided to follow it up further.
>>> This only happens with emacspeak53.0 or 54.0, previous versions have
>>> never crashed before.
>>> Here is the errors printed to the terminal from when it crashed
>>> those 4 times :
>>> $emacs
>>> Emacs-x86_64-10_14(2360,0x700009d2e000) malloc: *** error for object
>>> 0x70000a5307e8: pointer being f
>>> reed was not allocated
>>> Fatal error 11: Segmentation fault
>>> Abort trap: 6
>>> $emacs
>>> Emacs-x86_64-10_14(2433,0x700003241000) malloc: *** error for object
>>> 0x7ffee6db5200: pointer being f
>>> reed was not allocated
>>> Emacs-x86_64-10_14(2433,0x10a8415c0) malloc: *** error for object
>>> 0x7ffee6db5310: pointer being free
>>> d was not allocated
>>> Emacs-x86_64-10_14(2433,0x700003241000) malloc: *** set a breakpoint
>>> in malloc_error_break to debug
>>> Emacs-x86_64-10_14(2433,0x10a8415c0) malloc: *** set a breakpoint in
>>> malloc_error_break to debug
>>> Fatal error 6: Abort trap
>>> Abort trap: 6
>>> $emacs
>>> Emacs-x86_64-10_14(2497,0x70000ce9d000) malloc: *** error for object
>>> 0x7ffee91b45a0: pointer being f
>>> reed was not allocated
>>> Emacs-x86_64-10_14(2497,0x70000ce9d000) malloc: *** set a breakpoint
>>> in malloc_error_break to debug
>>> Fatal error 4: Illegal instruction
>>> Abort trap: 6
>>> $emacs
>>> Emacs-x86_64-10_14(2576,0x700002fcd000) malloc: *** error for object
>>> 0x7ffee07fcac8: pointer being f
>>> reed was not allocated
>>> Emacs-x86_64-10_14(2576,0x700002fcd000) malloc: *** set a breakpoint
>>> in malloc_error_break to debug
>>> Fatal error 4: Illegal instruction
>>> Abort trap: 6
>>> Do you know if there is anything I can do to fix this or is it a bug in
>>> emacspeak?
>>> It seems to me as though it is attempting to access a freed object.
>>> Has anyone else had this issue?
>> _______________________________________________
>> Emacspeak mailing list -- emacspeak(a)emacspeak.org
>> To unsubscribe send an email to emacspeak-leave(a)emacspeak.org

|May 1995 - Last Year|Current Year|

If you have questions about this archive or had problems using it, please contact us.

Contact Info Page