[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Search]

[Emacspeak] Emacspeak on Android


I've been trying to get Emacspeak working on my mobile phone, which is
running LineageOS 17.1 (based on Android 10).  So far, I've tried a couple
of things, but neither has quite worked.

First, I tried installing Emacspeak on debian-buster from proot-distro in
Termux.  Unfortunately, it's silent, and running espeak on its own results
in a long list of errors, starting with
> ALSA lib confmisc.c:767:(parse_card) cannot find card '0'
so I guess Termux's proot-distro isn't giving Debian access to the audio.

For another attempt, I tried building Emacspeak directly in Termux.  This
required building TclX, too, which seemed to work, but when I tried running
`./servers/espeak` it gave these errors
> couldn't load file
> "/data/data/com.termux/files/usr/lib/tclx8.4/libtclx8.4.so": dlopen
> failed: cannot locate symbol "rresvport" referenced by
> "/data/data/com.termux/files/usr/lib/tclx8.4/libtclx8.4.so"...
>     while executing
> "load /data/data/com.termux/files/usr/lib/tclx8.4/libtclx8.4.so Tclx"
>     ("package ifneeded Tclx 8.4" script)
>     invoked from within
> "package require Tclx"
>     (file "./servers/espeak" line 37)
so I guess TclX relies on rresvport, whatever that is, and Termux doesn't
provide it.

Does anyone have any clues about how I might be able to get Emacspeak
running on my phone?



|May 1995 - Last Year|Current Year|

If you have questions about this archive or had problems using it, please contact us.

Contact Info Page