[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Search]

Re: Help : links webbrowser + emacspeak

Tim Cross <tcross@xxxxxxxxxxx> writes:

> What version of emacspeak?
> Are you running under X or console mode?
console mode.
> Your setup sounds a bit strange. On my system C-c C-j puts you into
> line mode within lynx and C-c C-k puts you into character mode, which
> will enable the space bar to work to move to next page.
I tried that and it's true the C-c C-k puts into character mode (I think
it's the keybinding equivalent to the term-char-mode function). So great
it is the keybinding I was searching for yesterday and didn't find
myself ! thx !
but unfortunatly this keybinding interract badly with links (with "i")
and often when you try to switch to character mode using it it brings
you in a links window asking you for the link number you want to go to
or other times it has other stranges behaviour. So I have an idea :
perhaps this strange behaviour will not be here if we could remap the
term-char-mode to another keybinding different than C-c C-k ? what do
you think about this ? But unfortunatly I don't know how to do that. so
if someone know how to do to remap a function, please explain me.
thx in advance,

> With w3m, on my system the arrow keys do move you down to the next
> line. The tab key moves you to the next link. Try using C-h k to find
> out what is bound to the tab and the arrow keys (I'm assuming you are
> using the w3m.el package for w3m?)
Yes, I use that but here the up and down arrowq permit to read previous
and next line. exactly, I installed all the things from Debian testing
except emacspeak which is not available in 19.0 release for Debian.
> Tim
>>>>>> "Nath" == Nath  <nath.ml@xxxxxxxxxxx> writes:
>  Nath> Hello, i'm searching for a mean to be able to read text using
>  Nath> up and down arrow keys in emacspeak + links webbrowser.  I
>  Nath> launch links using the M-x emacspeak-links command and after
>  Nath> when the webpage is displayed I discover that if I do a C-c C-j
>  Nath> I switch to terminal line mode and after that can use the up
>  Nath> and down arrows to read the text but after that I don't find a
>  Nath> solution to switch to terminal caracter mode in order to be
>  Nath> able to press the space bar to tell links to display the next
>  Nath> things.  I tried the M-x term-char-mode but encounter a problem
>  Nath> : the caracter are not displayed correctly and sometimes it
>  Nath> brings me in a search window or something like that. so this
>  Nath> method is a wrong one but I didn't find the good one browsing
>  Nath> the emacs manual.  So if you have an idea please let me know !
>  Nath> Or perhaps the method I tried to use is not the right one,
>  Nath> perhaps we might not switch to term line mode to obtain the
>  Nath> research behaviour ?  I ask me a question : how is it possible
>  Nath> using w3m with emacspeak to be able to read text using up and
>  Nath> down arrows ? because when you launch w3m in a normal console
>  Nath> the behaviour is not the same, the arrow keys permit only to
>  Nath> skip link by link ...  thx in advance for all your advices,
>  Nath> -- Nath
>  Nath> -----------------------------------------------------------------------------
>  Nath> To unsubscribe from the emacspeak list or change your address
>  Nath> on the emacspeak list send mail to
>  Nath> "emacspeak-request@xxxxxxxxxxx" with a subject of
>  Nath> "unsubscribe" or "help"


To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@xxxxxxxxxxx" with a
subject of "unsubscribe" or "help"