Skip to Content.
Sympa Menu

emacspeak - [Emacspeak] Installing Emacspeak on Ubuntu

Subject: Emacspeak discussion list

List archive

[Emacspeak] Installing Emacspeak on Ubuntu

Chronological Thread 
  • From: Lanie Carmelo <laniegcarmelo AT>
  • To: emacspeak AT
  • Subject: [Emacspeak] Installing Emacspeak on Ubuntu
  • Date: Sat, 27 Apr 2024 23:22:55 -0500

Hi all. New subscriber here. I just put Linux on an old computer I have, and I'm trying to install Emacspeak. I've tried both the directions on the Emacspeak website and just installing the package found when I type sudo apt install emacspeak. When I tried the first option for the first time, make config didn't work, so I tried the second and got a Dpkg error code 1. I then tried following the directions on the website again, and this time I got to where I'm supposed to build a speech server. I chose eSpeak and made sure all eSpeak packages were installed. I tried to build it by typing make and got:

g++ -g    -O2 -fPIC  -DPIC  -pedantic -ansi -Wall -Wno-long-long --std=c++11 -I/usr/include/tcl8.6   -c -o tclespeak.o tclespeak.cpp
tclespeak.cpp:41:10: fatal error: espeak-ng/speak_lib.h: No such file or directory
   41 | #include <espeak-ng/speak_lib.h>
      |          ^~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make: *** [<builtin>: tclespeak.o] Error 1
rarebird15@rarebird15-HP-Laptop-14-dq0xxx:~/emacspeak/servers/native-espeak$ ^C

Has anyone else encountered this? Can you give me any suggestions on how to fix it? Thanks.

Archive powered by MHonArc 2.6.19+.

Top of Page