[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Search]

time-less-p symobol's definition is void?

OK, I should have looked a bit harder. Just for completeness ....

The function time-less-p is part of the dite-time package. I had made
some changes to my init file which commented out some packages when I
was trying to track down the auctex font-lock problem. One of these
packages must load something which requires time-date, which is why I
had not seen this error before. Once I put

(require 'time-date)

in my .emacs, I no longer get the error. 

Raman, do you think a require time-date should be put into the
emacspeak-speak.el file to avoid this error for users who may not be
loading something else which implicitly loads it?


>>>>> "Tim" == Tim Cross <tcross@xxxxxxxxxxx> writes:

 Tim> Hi All,

 Tim> This one is probably only answerable by Raman, but I figured I'd
 Tim> post it to the list so that if he replies it will be in the
 Tim> archives in case others encounter it.

 Tim> I was running emacspeak 19.0. I've written a driver for the
 Tim> Cepstral voices and decided to update to the latest CVS version
 Tim> of emacspeak before doing a final install/test of my
 Tim> modifications and sending them off to Raman for inclusion in
 Tim> emacspeak.

 Tim> When I start up the new install, I get an error relating to the
 Tim> emacspeak functions which check for new mail and notify you
 Tim> etc. The error says time-less-p definition is void. OK, no real
 Tim> problem, I expect this just means Raman has been doing some mods
 Tim> and they might not quite be complete yet. Just to check, I do a
 Tim> grep of the emacspeak sources I had installed before and find
 Tim> out that time-less-p was used there as well. Now I'm confused as
 Tim> I didn't get this error before (or maybe I just didn't notice
 Tim> it). I do some more checking. I load emacs with the -q
 Tim> -no-site-init and do an apropos for time-less-p. I get no hits,
 Tim> so it seems it is not part of the standard emacs
 Tim> distribution. If I run emacs with -q I get two hits for the
 Tim> apropos search, eldav-time-less-p and tramp-time-less-p, but
 Tim> still no time-less-p.

 Tim> Can anyone tell me where time-less-p is supposed to be defined?

 Tim> Tim

 Tim> -----------------------------------------------------------------------------
 Tim> To unsubscribe from the emacspeak list or change your address on
 Tim> the emacspeak list send mail to
 Tim> "emacspeak-request@xxxxxxxxxxx" with a subject of
 Tim> "unsubscribe" or "help"

To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@xxxxxxxxxxx" with a
subject of "unsubscribe" or "help"