[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Search]

Accent SA in Emacspeak-21

After a long break from this list, I'm back ;) The break was long
because Emacspeak worked so very well my friend had no need of
improvements or bug fixes for all these years, his Emacspeak/Outloud
ViaVoice machine performed flawlessly.

Until the powersupply went boom.

Taking the hard drive (and most components) with it.  it was very
dramatic, an actual 'boom' with billows of smoke and a horrible smell.

Anyway, I'm re-inventing his machine ground up, and attempting to
update things along the way, we managed to get Emacspeak-21 installed
with most of the common utilities like trplayer, but as you all know
ViaVoice is no longer an option.

I tried Festival, but the espeak.pl driver misses a lot of important
prompts such as VM's "do you want to save your mailbox?" messages.
The festival server also had stability problems, and the
restart-server command would just hang the machine. I tried the new
Java-based server, but it also has only spotty coverage over the
necessary messages.

Then, as luck would have it, we scored a dysfunctional Accent-SA that
I serendipidously could fix.

And here's where I've got problems: The mailing list archives only
mention the punctuation problem on the Accent SA as the last time it
was mentioned within the past 5 years.  

Our problem is more basic:

- the synth powers up and speaks it's welcome.

- I can run the accent driver (Emacspeak-ss 1.9.1) from the command
  line and it speaks it's welcome message.

- I can echo messages to /dev/ttyS0 and hear them spoken.

- I can start emacspeak and see the access driver in the process list.

but Emacspeak starts by speaking some long chain of gibberish that
contains what sounds like status or config option settings, lots of
"backslash" and something about DecTalk, and then stops.

and never speaks again.  Emacspeak will work silently for a while, then
jams solid and must be killed with -9 to restart.

Is anyone else using an Accent SA with Emacspeak-21?  Could there be
something changed since Emacspeak-ss 1.9.1 that is preventing this
from working?

or perhaps a more fundamental question: Is Emacspeak viable with an
Accent SA for a user who has no vision at all?  Or would he be better
off with SpeakUp?  (he's got several years emacs experience, so if we
should go with SpeakUp, it would need to have good emacs coverage)

any advice or pointers to further refs is most welcome.
Gary Lawrence Murphy <garym@xxxxxxxxxxx> ==============================
www.teledyn.com - blog.teledyn.com - irish.teledyn.com - sbp.teledyn.com
====================== The present moment is a powerful goddess (Goethe)

To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@xxxxxxxxxxx" with a
subject of "unsubscribe" or "help"