[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Search]

Re: update on speech server issue

Well, I've now tried running it under other shells (tcsh and csh), and
even installing my own copy of emacs 21.3.1 from source.  Nothing I can figure
out seems to make any difference.  Emacspeak 17 and 18 work, 19 and above do
not work.

When I start emacspeak >=19, using with the "-l" option or the "emacspeak"
script, the symptoms are identical as the emacspeak script.  Emacs appears to
be unable to start properly, and even commands like "c-x c-c" fail, with error
beeps and messages like "Buffer *Echo Area 1* has no process" the first time I
try it, and "Buffer *dtk-scratch-buffer* has no process" on subsequent
attempts, until the fourth or fifth attempt until it finally lets me out.

No error message on startup except the two I have reported before..."speech
server not running" and "ad-handle-definition: `occur-mode-goto-occurrence' got

Just to recap: the system is running SuSE 9.2.  I've tried installing the
RPM, but the SuSE tclx does not contain the "tcl" binary that emacspeak needs,
so I ended up installing tcl, tk, and tclx from source.

All versions of emacspeak then build, and 17 and 18 work.  19 and 20 do not.

I have tried installing a local version of emacs.  I've tried running
emacspeak using the "emacspeak" script, as well as:

"emacs -no-site-file -q -l

With both the SuSE emacs and now my local emacs.  It still does not work.

Any ideas?


To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@xxxxxxxxxxx" with a
subject of "unsubscribe" or "help"