[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Search]

xslt transform to linearize tables was:Re: what is the best way toread webpages presented with html tables ?

Nath <nath.ml@xxxxxxxxxxx> writes:

> Jason White <jasonw@xxxxxxxxxxx> writes:
> ...
>> a better way is to use the XSLT style sheets supplied with Emacspeak,
>> which can be applied automatically to a Web page before it reaches the
>> browser. Several of the style sheets are specifically designed to
>> handle tables.
> Ok. I tried to apply your advice ; so I tried to use the functions
> emacspeak-w3-xslt-select and emacspeak-w3-xsl-toggle but it doesn't work
> for me here. so i browsed the list archive and find this message :
> https://www.emacspeak.org/VCCS-archive/list.archive.2002/msg00769.html
> the important part of this message follows :
> Yvonne thomson said :
> "All I do is use the xslt stuff that I'd use in w3. What I've done is
> create my own hotkeys in w3m one for turning async mode on and off,
> since xslt stylesheets don't work with async mode on. One for the
> stylesheet toggle and one for the select stylesheet option. The only
> inconvenient thing is that you have to load w3 first, then w3m, but
> other than that it works fine."
> But could someone give me more precisons about this explanation ? My
> questions : How to create personnal hotkeys ? what is async mode in w3m
> and how to turn it on and off ? 
> yvonne said also that we must load w3 before loading w3m to have the
> table linearization to work but ddoes it mean that I must physically
> load w3 in a buffer or can I just add a line in my .emacs file in order
> to have the w3 code loaded ?
> Thx in advance for all your explanations and advices on how to pproceed
> to do what Yvonne explains and excuse for my newbie questions,
> Best regards,
So, I tried to do what Yvonne explained but now after loading w3 in a
separate buffer, loading w3m, executing emacspeak-w3-xslt-select and turning on
emacspeak-w3-xsl-toggle the webpage I try to load are not displayed on
the screen at all ! If I turn off emacspeak-w3-xsl-toggle the content of
the page is displayed again. So, what I'm missing ? what I'm doing wrong
? Perhaps I don't turned off w3m async mode pproperly since I don't know
exactly what it is : what I did was to toggle off the two variables w3m
async exec and w3m process conection type in the w3m customization group
all your ideas will be very appreciated ! thx,


To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@xxxxxxxxxxx" with a
subject of "unsubscribe" or "help"