[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Search]

Re: update on speech server issue

Thanks for the suggestions.

> 1. Check the messages buffer for any errors when emacs loads the
>    emacspeak files. It is possible this information may have scrolled
>    out of the buffer if a lot of other packages are loaded after
>    loading emacspeak.

I tried tailing /var/log/messages when I loaded emacspeak, but nothing
comes up.  In fact, if I go into /var/log and run:

% find . -exec grep emacs {} --with-filename \;

I find no instances of emacs.

> export TCL_PROGRAM=tcl
> Assuming extended tcl is called tcl on your system.

I tried that, and it made no difference.  I also tried setting it with
the full path of the tcl executable and it did not help.

I still have the SuSE tcl packages removed from this system, so this SHOULD
be the only tcl binary installed.

The messages that flash by are in the very bottom window, titled *Compile-Log*
in bold.  After the "the speech server is not running" message, the final
message displayed is "Buffer *scratch* has no process"

>   I would try doing it with the full path, just to make sure there
>   isn't something funky happening with the path setting e.g.
> tcl /usr/share/emacs/site-lisp/emacspeak/servers/dtk-exp

I had tried this, and I tried it again...it still works fine.

HOWEVER, after doing some more experiments, I found that emacspeak-17.0
and emacspeak-18.0 work just fine on the system.

emacspeak-19.0, 20.0 and 21.0 do not work, they demonstrate the same problem.


To unsubscribe from the emacspeak list or change your address on the
emacspeak list send mail to "emacspeak-request@xxxxxxxxxxx" with a
subject of "unsubscribe" or "help"